
Programming using the ASR-Soft

ASR-Soft provides a user-friendly interface wherein the user has to only select contact type and contact 
number and place it where it is required. Contacts get connected automatically if they are on the same line. 
User can enter comments for better readability and for future reference .

Entering the Program: Select & Place

ASR-Soft  allows user to save individual programs on the PC.
Saving Programs

ASR-Soft is very powerful in error handling. It displays any possible errors as the program is being entered 
to make corrections simultaneously.

Debugging

User can simulate the program on PC. User can use buttons provided on the screen to simulate the input 
connections. Scroll bar can be used to simulate Analog input. The actuation/ de-actuation of the relays can 
be monitored on the screen. 

Simulation on PC

User can take print outs of programs in two different formats, namely Short format and Detail format. Also, program Parameters and Comments can be printed.
Printing

Programs can be transferred from PC to Altech Smart Relay and vice versa using serial Communication cable / USB cable. This saves the program entering time on the Smart 
Transfering Programs

With this utility user can set the clock (date and time) on the Altech Smart Relay.
Transfering Clock

User can connect the Altech Smart Relay unit to PC using a serial Communication cable / USB cable and perform on line program simulation. In this mode the PC acts as a 
master and the inputs are taken from Altech Smart Relay and outputs are sent to Altech Smart Relay unit (and the extension modules, if connected). This mode is useful in 
debugging the entire system since the actual I/Os are used.

Simulation on Altech Smart Relay 

ASR-Soft is the exclusive Windows   based programming software for the Altech Smart Relay . It facilitates:

Select File -> New from the menu bar to create a new program.
A blank screen will appear. Now you can start entering the program. Ensure that you have chosen proper Altech Smart Relay Configuration before starting the program entry.

Position the cursor at the place where you want to insert the contact by a left click with mouse. The position will get highlighted. Choose the required contact type and Contact 
Number from I/O function selector. Click on the required contact and contact number, which will be highlighted for a few seconds. The selected contact will appear at the 
position selected in the program. The selected contact number will be shown with a tick mark to indicate that it has been used in the program. You can right click on any of the 
contact to change its type and properties.

Choosing Contact Type

Each circuit connection runs from left to right. Please remember this when you interconnect contacts and relay coils. User can draw a circuit connection horizontally from left 
to right and vertically between adjacent circuit connections. An intersection of circuit connections represents an electrical connection.

Connecting Inputs & Outputs

To make a horizontal connection, click on the horizontal dotted line in the connection box of the circuit. Or to make connection in contact box, press right button and select 
"Joining link". Generally when an output coil is placed in the fourth column, it gets automatically connected.

Horizontal connection

To make a vertical connection click on the vertical dotted line in the connection box of the circuit. Vertical connection represents OR connection. For deleting a connection 
just left click on the connection line.

Vertical connection
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Working with ASR-Soft

To Set Communication Parameters

Clock Setting

DST (Daylight Saving Time) Setting

Transfer Options
PC to Device

Device to PC

Extension Module Selection

To Configure Communication Port

To Set & Remove Password

Screen - 1

Screen - 2

Screen - 3

Screen - 4

Screen - 5

To Set Backlight Mode
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Ÿ Select the Configuration >Device Utilities menu command. Then Device Utilities window 
will pop up as shown in the Screen - 1

Ÿ Click on set password. 
Ÿ Enter four digits password in the two boxes “New password” and “Confirm New” 

Password then confirm with OK. 
Ÿ You can delete your assigned password at any time. To do this, enter the existing password 

in “Old password” box. Then confirm with OK.
Ÿ To change the password, you must first enter the new password in the two boxes “New 

password” and “Confirm Password “ and the existing password in Current password text 
box. Then confirm with OK.

Ÿ Select the Configuration >Device Utilities menu command. Then Device Utilities window 
will pop up as shown in the Screen - 1.

Ÿ Select the mode Auto, On or Off then click on the set mode button.
Ÿ Then “The requested operation will move the device out from the run mode. Do you want 

to continue?” message will pop up.
Ÿ If pressed Yes, then backlight mode will get set in device and "Backlight mode has been set 

successfully" message will appear on the screen.

Ÿ

up as shown in the Screen - 2 showing two option buttons to select the Port.
Ÿ Select “Device is connected to USB port” when the device is connected with cable.
Ÿ Select “Device is connected to Serial Communication port” when the device is connected 

with Serial Communication cable.

Select the Options > Comm port menu command. Then COM Port setting window will pop 

Ÿ

up as shown Screen - 2.
Ÿ The user can set the following communication parameters:
       SLAVE ID: Selectable from 1 to 247.
       BAUD RATE: Selectable as 1200,2400,4800,9600 baud.
       PARITY: Selectable as NONE, EVEN and ODD.
       STOP BIT: Selectable as 1 and 2 stop bits.

Select the Options > Comm port menu command. Then COM Port setting window will pop 

Ÿ

up as shown in the Screen - 3.
Ÿ To view Date and time of device: Click Read button on the clock setting window. Then the 

Clock Setting window will show the Date and Time of the device.  
Ÿ To set Date and time in the device: User can select Date and Time to write into the device. 

Click Write  button on the clock setting window.

Select the Transfer > Device Clock menu command. Then Device Clock window will pop 

Ÿ

up as shown in the adjoining window.
Ÿ To set Enable DST, Follow the following steps: Click Daylight Saving Time check box then 

the DST setting section becomes visible.
Ÿ User can select the following parameters: Begin Week, Begin Day, Begin Month, Begin 

Time, End Week, End Day, End Month, End Time, Offset Time 
Ÿ To set Disable DST, Follow the following steps:
      1. Deselect Daylight Saving Time option then DST window will get disable.
      2. Press Set DST.
Ÿ     To read DST: Press Read DST, independent of the DST enable or disable. 

Select the Transfer > Device Clock menu command. Then Device Clock window will pop 

Ÿ

in the Screen - 4.
Ÿ Press "PC to Device" button on transfer dialog box. Current program on the screen will get 

transferred to device.
Ÿ Transfer completion message "The Program is downloaded successfully" will appear on the 

screen. 

Select the Transfer > Program menu command. Then transfer window will pop up as shown 

Ÿ

in the Screen - 4.
Ÿ Press "Device to PC" button on transfer dialog box. Current program 

on the screen will get transferred to device.
Ÿ Transfer completion message "The Program is downloaded 

successfully" will appear on the screen. 
Ÿ Read program will be shown on main screen.

Select the Transfer > Program menu command. Then transfer window will pop up as shown 

Ÿ

Selection window will pop up as shown Screen - 5. 
Ÿ Selection of Altech Smart Relay model and Extension modules. 

Maximum three extension modules can be connected to one Base 
Module.

Select the Configuration >PLC Model menu command. Then Model 



Sample Programs

FACTORY/SCHOOL SCHEDULE
Opening bell at 8am announces start of work or class (bell to last 10 sec and stop): Bell at 10:30am announces start of coffee break, Bell at 10:45am announces end of coffee 
break, Bell at 12noon announces lunch, Bell at 12:45 announces end of lunch, Bell at 5pm announces end of work day

7. Select Timer T1 from the I/O selector window and place it in the coil column of line 1and contact column of line 7. 
8. Open the Timer properties window and select the mode as Interval and enter the time duration i.e. SP as 10 sec.
9. Connect the lines from all the Time Switches to the Timer as shown in screen.

10. Select Output Q1 from the I/O selector window and place it in the coil column
11. Right click on output Q1 to and select the option ‘State Change: Contactor’

1. Click on the Time Switch symbol in the I/O selector window and select Time Switch 1 (    1) 
2. Move the cursor to the ‘Contact 1' column of the first row and left click on the block to place the Time Switch.
3. Right click on the Time Switch and select properties to open the properties window.
4. In the Weekday settings option select ‘From’ as Monday ans ‘To’ as Saturday.
5. In the Daily Duration option enter the start time as 10:30 and since we want the siren for 10 sec. enter end time as 10:31.
6. Similarly select the other 5 Time Switches and enter the times as described above and place them in the contact 1 column of lines 2, 3, 4, 5 & 6.

Time Switch Selection  & Parameter Editing

Programming

Timer Selection  & Parameter Editing

Output Configuration

LADDER PROGRAM

For the 6 time periods 6 Time Switches are required.                         represent the 6 Time Switches.
Timer T1 ensures that the duration of the output is 10 seconds only.
Q1 represents the Output Coil (Alarm/Bell in this case)
Double click on the ASR Soft  icon the launch the ASR Soft  Software application.
Click on File   New to launch a new Program window.

 1,   2, .....   6
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Sample Programs

CAR PARKING
There are 5 parking spots available in a parking area. There are 2 sensors, one at the entry gate and one at the exit gate. When all the parking spots are occupied, there is a lamp 
outside the entry gate indicating parking is full. When any of the parking spots is available, other lamp is switched ON indicating parking is available. 

5.   Select Counter C1 from the I/O selector window and place it in the coil column of line 1. Right click on the counter and select the option counting input. 
6.   Again select the same counter C1 and place it in the coil column of line3 . Right click on the counter and select the option direction input. 

1.   Click on the Input symbol in the I/O selector window and select I1.
2.   Move the cursor to the Contact 1 column of the first row and left click on the block to place the input.
3.   Again click on the Input symbol in the I/O selector window and select ‘I2’.
4.   Move the cursor to the Contact 1 column of the second t row and left click on the block to place the input. Also place it in the Contact 1 column of the third row.

Input Selection

Programming

Counter Selection  & Parameter Editing

Compare Counter Selection  & Parameter Editing

Input I1is the sensor at the Entry gate and Input 2 is the sensor at the exit gate. 
Output Q1 indicates that Parking is available, Output 2 indicates that Parking is Full.
Counter C1 is used to count the number of vehicles that have entered or exited the parking.
Compare Counters P1 & P2 are used switch ON outputs Q1 & Q2 respectively  by  comparing the count of counter C1.

  7. Select Compare Counter P1 from the I/O selector window and place it in the contact column of line 4. 
  8. Right click on the compare counter and select properties. 
  9. Under the compare selection option, select ‘F1’ as ‘C1’, ‘OP’ as ‘<’, ‘F2’ as ‘Abs Value’ and reference count as 5. 
10. Select Compare Counter P2 from the I/O selector window and place it in the contact column of line 5. 
11. Right click on the compare counter and select properties. 
12. Under the compare selection option, select ‘F1’ as ‘C1’, ‘OP’ as ‘=’, ‘F2’ as ‘Abs Value’ and reference count as 5. 

13. Select Output Q1 from the I/O selector window and place it in the coil column
14. Right click on output Q1 to and select the option ‘State Change: Contactor’

Output Configuration

LADDER PROGRAM
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Altech Smart Relay provides 2 types of Inputs viz. 
AC Model: Digital Inputs (1 - 8) 
DC Model: Digital Inputs (1 - 6), Analog Inputs (V1, V2)8

Digital & Analog

INPUTS

TIMERS

Q1, Q2, ..... Q4 Base Module 

Extension Module 3

Extension Module 2

Extension Module 1Normally Open 
Contact

(’NO’ Contact)

U1, U2, ..... U4

V1, V2, ..... V4

W1, W2, ..... W4

q1, q2, ..... q4 Base Module 

Extension Module 3

Extension Module 2

Extension Module 1Normally Closed 
Contact

(’NC’ Contact)

u1, u2, ..... u4

v1, v2, ..... v4

w1, w2, ..... w4

Altech Smart Relay provides Base Module (4), Extension 
Module (4)
The outputs can be configured as: 
I. State Change (Contactor), ii. Level Change (Remote Control), iii. Bi-stable 
(Set Reset)

Digital Outputs: 
OUTPUTS

I1, I2, ..... I8 Base Module 

Extension Module 3

Extension Module 2

Extension Module 1Normally Open 
Contact

(’NO’ Contact)

J1, J2, ..... J8

K1, K2, ..... K8

L1, L2, ..... L8

i1, i2, ..... i8 Base Module 

Extension Module 3

Extension Module 2

Extension Module 1Normally Closed 
Contact

(’NC’ Contact)

j1, j2, ..... j8

k1, k2, ..... k8

l1, l2, ..... l8

Altech Smart Relay 16 Soft Text Message blocks which can be 
used to display text messages, the Preset Value and Current Value of any 
Special Function Block or the Current Date and time

 provides 

SOFT TEXT MESSAGES

X1, X2, ..... X16 Used for viewing Alarms, HMI Functionality

Altech Smart Relay 16 Timers which can be configured as:
I. ON Delay, ii. Off Delay, iii. Single Pulse iv. Symmetric/Asymmetric

 provides 

v. Equal/Unequal On/Off 2, vi. Equal/Unequal Off/On 2,
vii. Leading Edge Impulse 1, viii. Leading Edge Impulse 2
ix. Trailing Edge Impulse 1, x. Trailing Edge Impulse 2 
xi. Delayed Impulse, xii. Impulse On/Off, xiii. Signal Off/On.   

T1, T2, ..... T16

t1, t2, ..... t16

Timer Coil / Normally Open (NO) Contact

Normally Closed (NC) Contact
Trigger Input

Timer Mode

Locked/Unlocked State
Make/Break Status of ‘NO’ Contact

Preset Time Period

Current Time Period

Timer Number

Preset Time Unit

Current Time Unit

Reset Input
  D      TRG        T1
           RES        X
  S      000.0       OF
  S      006.0       OF

  D      TRG        T1
           RES        X
  S      000.0       OF
  S      006.0       OF

Altech Smart Relay 16 Time Switches which can be used for daily or 
weekly applications

 provides 

TIME SWITCHES

 1,   2, .....   16

 1,   2, .....  16

Normally Open (NO) Contact

Normally Closed (NC) Contact

  D      TRG        T1
           RES        X
  S      000.0       OF
  S      006.0       OF

         MO   SU        
          08 :  11         1
ON     09 :  15     X
OFF   12 :  00    

From To

Time Switch No

Make/Break Status 
of ‘NO’ Contact

Locked/Unlocked State

Start Time

End Time 

Current Time

Altech Smart Relay 16 Compare Counters which can be used for 
comparison between values of two counters or between a counter and any 
absolute value
I. Up Counter, ii. Down Counter

 provides 

COMPARE COUNTERS

P1, P2, ..... P16

p1, p2, ..... p16

Normally Open (NO) Contact

Normally Closed (NC) Contact

  D      TRG        T1
           RES        X
  S      000.0       OF
  S      006.0       OF

        COMPARE      
C1         0000
                >           P1   
ABS      1023        X   

Make/Break Status of ‘NO’ Contact

Compare Counter No

Locked/Unlocked State

Compare Function

Absolute Value 

Compare Input

Altech Smart Relay 12 Analog Comparators which can be used 
for comparison between values of two analog signals or between a an 
analog signal and any absolute value

 provides 

ANALOG COMPARATORS

A1, A2, ..... A12

a1, a2, ..... a12

Normally Open (NO) Contact

Normally Closed (NC) Contact

  D      TRG        T1
           RES        X
  S      000.0       OF
  S      006.0       OF

          ANALOG      
V1         0000
                >           P1   
ABS      1023        X   

Make/Break Status of ‘NO’ Contact

Analog Comparator No

Locked/Unlocked State

Compare Function

Absolute Value 

Compare Input

Altech Smart Relay 64 Auxiliary relays which can be used to expand a 
rung from one line to another line.
It can be configured as: 
I. State Change (Contactor), ii. Level Change (Remote Control), iii. Bi-stable 
(Set Reset)

 provides 
AUXILIARY RELAYS

M1, M2, ....M64

m1, m2, .....m64

Auxiliary Coil / Normally Open (NO) Contact

Normally Closed (NC) Contact

Altech Smart Relay 16 Counters which can be configured as:
I. Up Counter, ii. Down Counter

 provides 

Z-Keys are navigation keys provided on device front facia.They behave 
exactly like the physical inputs (Discrete inputs). The only difference is 
that they do not correspond to Altech smart relay connection terminals, but 
to the four gray buttons on the front panel.

·Z-Keys can be used as navigation keys for current displayed menu. 
To use Z-Keys go to RUN Screen or RUN LADDER Screen and Press 
ALT which will display the Z-Key Screen. Then Press Z1 - Z4.

COUNTERS

Z-KEYS

C1, C2, ..... C16

c1, c2, ..... c16

Counter Coil / Normally Open (NO) Contact

Normally Closed (NC) Contact

Z1, Z2, ..... Z4

z1, z2, ..... z4

Normally Open (NO) Contact

Normally Closed (NC) Contact

  D      TRG        T1
           RES        X
  S      000.0       OF
  S      006.0       OF

           0004      0000          
            DIR        RET
            CNT     C1  N
            RES      X

Preset Value

Locked/Unlocked State
Make/Break Status
 of ‘NO’ Contact

Retentive Selection (Y/N)

Current Value

Counter Number

Counter Unit

Reset Unit

Direction Input

Ladder Programming Elements / Function Blocks

6

In ladder programming, the ladder elements / Functional Blocks are connected to create a ladder for any application. The following section gives the description of 
each element that is used for ladder programming.


